Mitsubishi iQ Platform Compatible
Programmable Controller Engineering Software
MELSOFT GX Works2 FB Quick Start Guide

Let's learn FB!

'EASY', 'EASY-TO-READ', AND 'REDUCTION OF MAN-HOURS'

1. How to read this guide
2. Terms
3. Related manuals
4. Introduction
5. FBs
6. Using FB Libraries
7. Creating FBs

MELSEC Q series
MELSEC L series
MELSOFT
How to read this guide

The following shows the symbols used in this Quick start guide with descriptions and examples.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Point" /></td>
<td>This symbol explains information you need to know.</td>
<td>Select [View] → [Comment] (Ctrl key + F4 key). The comment display/hide setting can be switched.</td>
</tr>
<tr>
<td><img src="image" alt="Caution" /></td>
<td>This symbol describes content that must be noted in operation.</td>
<td>When dismounting the module, the power must be turned off.</td>
</tr>
<tr>
<td><img src="image" alt="Buttons" /></td>
<td>Buttons on the screen</td>
<td><img src="image" alt="OK button" /></td>
</tr>
<tr>
<td><img src="image" alt="Menu" /></td>
<td>Menu names on the menu bar ([ ] → [ ] shows drop-down menus.)</td>
<td>Select [Project] → [New].</td>
</tr>
<tr>
<td><img src="image" alt="Keys" /></td>
<td>Keys on the keyboard</td>
<td><img src="image" alt="F4 key" /></td>
</tr>
<tr>
<td><img src="image" alt="Another procedure" /></td>
<td>Another procedure corresponding to a drop-down menu (icons and keys on the keyboard)</td>
<td>Select [Compile] → [Rebuild All]. (F4)</td>
</tr>
</tbody>
</table>

Terms

The following explains the terms and abbreviations, such as FB, used in this Quick start guide.

<table>
<thead>
<tr>
<th>Term or abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FB</td>
<td>Abbreviation of Function Block.</td>
</tr>
<tr>
<td>FB library</td>
<td>A collection of FB parts that are usable in GX Works2 (Simple Project). Sequence programs to use MELSEC-Q/L series modules and partner products can be easily created.</td>
</tr>
<tr>
<td>GX Works2</td>
<td>A programming tool for the programmable controller. Programming using FB libraries is possible. Generic product name of product types SWnDNC-GXW2-E. (n = version)</td>
</tr>
<tr>
<td>GX Developer</td>
<td>A programming tool for the programmable controller. Generic product name of product types SWnD5C-GPPW-E. (n = version)</td>
</tr>
</tbody>
</table>
Related manuals

This Quick start guide explains the basic procedures to introduce FB. Refer to the manuals in the following table as required.

<table>
<thead>
<tr>
<th>Manual name</th>
<th>Manual number (Model code)</th>
</tr>
</thead>
<tbody>
<tr>
<td>GX Works2 Version 1 Operating Manual (Common)</td>
<td>SH-080779ENG (13JU63)</td>
</tr>
<tr>
<td>Explains the common functions of both simple and structured GX Works2 projects, including operation methods for system configuration, parameter settings, and online functions. (Sold separately.)</td>
<td></td>
</tr>
<tr>
<td>GX Works2 Version 1 Operating Manual (Simple Project)</td>
<td>SH-080780ENG (13JU64)</td>
</tr>
<tr>
<td>Explains operation methods, such as program creations and monitors using simple projects in GX Works2. (Sold separately)</td>
<td></td>
</tr>
</tbody>
</table>
Introduction

This Quick start guide explains the basic procedures for first-time FB (Function Block) users. This guide will help with understanding how to use FBs.

Quick start guide

- What is FB?
  - Explains the overview of FB.
  - Explains the advantages and features of using FBs.

- How to use FBs?
  - Explains the preparations required prior to use an FB library.
  - Explains the procedures for creating a simple sequence program using an FB library.

- How to create an FB?
  - Explains the procedures for creating an FB with examples.

Caution

This Quick start guide explains how to use FB libraries and how to create FBs using simple examples. When designing/operating systems, read the manuals of the CPU module that is to be used, that in use, and use them safely.
FBs

FB is an abbreviation for a Function Block that is designed to convert a ladder block, which is used repeatedly in a sequence program, into a component (FB) to be utilized in a sequence program. This not only increases the efficiency of program development but also reduces programming mistakes to improve program quality.

Sequence program

Converting into Components

What does it mean when a sequence program is converted into a component? The following section explains the process to convert a simple program into a component.

Example) A program in which the output signal (Y12) is turned ON when the input signal (X1) is turned ON 12 times.
Advantages of Using FBs

This section introduces advantages of creating programs by using FBs.

■ Easy programming

A sequence program can be created simply by pasting in an FB. This significantly reduces the program development man-hours. (Programming is made easier using FB libraries provided by Mitsubishi Electric Corporation.)

■ Easy reading

Using an FB creates a simple program with only a 'box' (FB), an input, and an output to create an easy-to-read sequence program.
Reusing

Converting a standard program into a component allows the program to be reused any number of times.

As a result, operations such as copying a sequence program and modifying a device, which had often been required in the past, will be unnecessary.

Improving quality

Converting a standard program into a component as an FB to reuse the program allows development of programs of consistent quality, without relying on the technological skill of the program developers.

When developers A and B are developing sequence programs for different devices, using the same FB for the common processing enables to create consistent quality of sequence programs.
Protecting assets

By setting up a block password, the created FB can be protected so that it cannot be viewed. Once the block password has been set, the following operations are restricted:

- Displaying and editing of FB program
- Editing of FB local label
- Copying to other project
FB Libraries

An FB library is a collection of FB parts that are usable in GX Works2 (Simple project). Using an FB library enables easy setting and operation of MELSEC-Q/L modules and partner products.

<Example of MELSEC-Q/L module>

<Example of partner product>

Partner product lineup
FB Library Lineup

In FB libraries, there are ‘FBs for MELSEC-Q/L modules’ and ‘FBs for partner products’.

<table>
<thead>
<tr>
<th>FBs for MELSEC-Q/L modules</th>
<th>FBs for partner products</th>
</tr>
</thead>
<tbody>
<tr>
<td>-CPU</td>
<td>-Vision sensor</td>
</tr>
<tr>
<td>-Analog input/output module</td>
<td></td>
</tr>
<tr>
<td>-Counter module</td>
<td></td>
</tr>
<tr>
<td>-Positioning module</td>
<td></td>
</tr>
</tbody>
</table>

FB libraries supporting various functions are expected to be released sequentially.

How to Obtain FB Libraries

Contact your local Mitsubishi representative to obtain the FB Library.
Development Tool

The following development tool is required to develop sequence programs using FBs.

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>GX Works2 (Simple project)</td>
<td>1.12N or later</td>
</tr>
</tbody>
</table>

Point

Depending on the FB library, supporting versions of GX Works2 may differ.

FB Specifications and Precautions

The following specifications and precautions must be understood prior to using FBs.

1. An FB cannot be used in another FB.
2. Because an FB specific process is added when an FB is arranged, the number of steps increases when compared to a ladder created without using an FB.
3. FBs cannot be used in an interruption program.
4. FBs whose execution does not complete within 1 scan cannot be used in the FOR to NEXT instruction loops and subroutine programs.
Using FB Libraries

This chapter explains the procedure to create a program by using an FB library.

1. Creating New Projects P.16
2. Importing FB Library to Projects P.19
3. Pasting FBs P.21
4. Setting Names of the Pasted FBs P.22
5. Creating Input and Output Ladders P.23
6. Performing Conversion/Compilation P.24
7. Writing and Executing Sequence Programs P.25
8. Confirming Operations P.26

Caution
Before using FB libraries, read and agree to the terms of use indicated when obtaining an FB library.
Programs to be Created

This section explains how to use an FB library with an example of importing an analog value from an analog input module.

Example) Reading an analog value to D10 from the analog input module (Q64AD) when the switch (X10) is turned ON.

Program can easily be created by using an FB library as follows.

Create this program in the following section.
Preparations Prior to Use of FB Libraries

Before using an FB library, contact your distributor to obtain it.

(FB libraries will not be installed when installing GX Works2.)

The following explains operation procedures using the FB library for Q64AD as an example.

**Operating procedure**

1. As the file obtained from your distributor is a zip format file, unzip "q64ad_v100a.zip" and start installation.

![File Structure]

Double-click "setup.exe" in the unzipped folder.

2. The installation screen is displayed.

The screen for installation is displayed.

Follow the instructions and perform installation.
3. The following dialog is displayed when the installation is complete.

![InstallShield Wizard Complete]

Click the Finish button to close the dialog.

This completes the preparation prior to use of FB libraries.
How to use the reference manual
For details of the installed FBs, refer to the reference manual. The reference manual is installed along with the FB library.

The following explains how to access the reference manual.

**Operating procedure**

1. Select the FB for the reference manual to be displayed, and right-click and select [Data Help] from the shortcut menu.

2. A help file in PDF format is displayed.

3. The page for the selected FB is displayed.

The reference manual for the selected FB is displayed.
Creating New Projects

This section explains how to create a new project by starting GX Works2.

Operating procedure

1. Select [Start] → [All Programs] → [MELSOFT Application] → [GX Works2] → [GX Works2].

2. After starting, the GX Works2 main screen is displayed.

Menu bar
Navigation window
Project view
Function Block Selection window
3. Select [Project] → [New].

![Project menu with New... selected]

4. The "New Project" dialog is displayed.

![New Project dialog]

- Select "Simple Project".
- Check "Use Label" (always check this item).
- Select "PLC Series". (In this example, QCPU (Q Mode) is selected.)
- Select QCPU to be used.
- Select a language to be used for development.
- Click the OK button.

5. A project tree and the ladder screen are displayed.

![Project tree and ladder screen]

- A project tree is displayed in the Project view of the Navigation window.
- The ladder screen is displayed.
If the Navigation window is not displayed, use the following procedure to display it.

1. Select [Docking Window].
2. Select [Navigation Window].

If the Function Block Selection window is not displayed, use the following procedure to display it.

1. Select [Docking Window].
2. Select [Function Block Selection Window].
Importing FB Library to Projects

This section explains how to import an FB library for analog input module (Q64AD) to be pasted to the program into a project.

Operating procedure

1. Select [Project] → [Library] → [Install].

To the next page.
2. The "Install" dialog is displayed.

   - Select "Q64AD".
   - Click the **Refresh FB List** button.
   - Check the library to import.
   - Click the **OK** button.

3. The imported FBs are displayed in the Project view and the Function Block Selection window.

The FB library for Q64AD is now usable in GX Works2. Next, create a program using the imported FB library.
This section explains how to drag and drop the FB to be pasted to the program window from the Function Block Selection Window or Project view. (Drag and drop from the Project view is possible from GX Works2 1.24A or later.)

### Operating procedure

1. Paste "M+Q64AD_ReadADVal" to the program window.

   ![Image of Function Block Selection window](image1.png)

   ![Image of Project view](image2.png)

   From the Function Block Selection window or Project view, drag and drop the FB to the place where FB will be pasted.

2. The "Input FB Instance Name" dialog is displayed.

   ![Image of Input FB Instance Name dialog](image3.png)

   For details of settings, refer to section '(4) Setting Names of the Pasted FBs' in the following page.
Setting Names of the Pasted FBs

When an FB library is pasted to the program window, a dialog to input a name of the pasted FB (FB instance name*) is displayed.

* Instance name is to distinguish the FB.

A temporary name is automatically set to the instance name. To use the name as it is, close the dialog by clicking OK. Make sure that the same name does not exist in the same program when changing the name.

Keep as the default in this procedure.

Operating procedure

1. Input the FB instance name.

   ![Input FB Instance Name](image)

   - Input the FB instance name (*ReadADVal_1* in the example).
   - Click the OK button.

2. The FB is pasted to the program window.

   ![ReadADVal_1](image)

Point

When inputting an instance name, be careful of the following points.
- Case-sensitive
- Single-byte number cannot be selected for the first letter.
- The maximum number of characters for an instance name is 16 in single-byte.

An error occurs when clicking OK with the following setting.
(When the first letter is a single-byte number).
Creating Input and Output Ladders

Create the input ladder section and the output ladder section of the pasted FB, and complete the program.

Refer to the following drawing and input the information.

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(1)</td>
<td>FB execution instruction</td>
</tr>
<tr>
<td>(2)</td>
<td>Module mounting XY address: 0</td>
</tr>
<tr>
<td>(3)</td>
<td>Channel number: 1</td>
</tr>
<tr>
<td>(4)</td>
<td>FB is running: ON</td>
</tr>
<tr>
<td>(5)</td>
<td>Normal end: ON</td>
</tr>
<tr>
<td>(6)</td>
<td>Error end: ON</td>
</tr>
<tr>
<td>(7)</td>
<td>Stores the error code.</td>
</tr>
<tr>
<td>(8)</td>
<td>Stores the analog value.</td>
</tr>
</tbody>
</table>
Performing Conversion/Compilation

Conversion/compilation is required to execute the completed program. The following explains how to convert/compile all programs.

Operating procedure

1. Select [Compile] → [Rebuild All].

2. The following message is displayed.

3. All programs are converted/compiled and the result is displayed in the Output window.

This completes the program creation.

Point

When pasting multiple FBs that describe the device output (such as OUT Y0Z9) by using index modification internally, duplicate coil warnings occur during compiling. However, this is not a usage problem.
Writing and Executing Sequence Programs

Write the created program to the CPU module and run the program.

Operating procedure

1. Select [Online] → [Write to PLC].

2. The "Online Data Operation" dialog is displayed.

3. Data are written to the programmable controller CPU.

Preparation to run the created program is now completed.

Point

Writing symbolic information using the Write to PLC function enables restoring to FB when the program is read from the programmable controller. In addition, for universal model QCPU and L series CPU modules, program memory for the programmable controller can be economized by changing the write destination of the symbolic information to the CPU module built-in standard ROM.
Confirming Operations

Confirm the created program’s operations.

Operating procedure

1. Select [Online] → [Monitor] → [Start Monitoring].

2. Monitoring status is displayed.

To the next page.
3. Turn the switch (X10) ON and confirm that the analog value is read.

Double-clicking the FB in the sequence program on the screen enables monitoring of the sequence program status in the FB.

This concludes the explanation of how to use FB libraries.
Creating FBs

This chapter explains the procedure to create a new FB.

Create an FB with the following procedures.

1. Creating New Projects
2. Creating New Data
3. Setting Labels
4. Creating FB Programs
5. Performing Conversion/Compilation

- FBs to be Created (P.29)
- Creating New Projects (P.30)
- Creating New Data (P.32)
- Setting Labels (P.33)
- Creating FB Programs (P.35)
- Performing Conversion/Compilation (P.36)
- Protecting Created FBs (P.38)
- Utilizing FBs in Other Projects (P.40)
- Techniques for Creating FBs (P.42)
FBs to be Created

This section explains the procedure to create an FB from a simple program.

Example) When input X1 is turned ON 12 times, output Y12 is turned ON.

[Sequence program]

[Timing chart]

Creating an FB for the above program and pasting it to the sequence program creates a simple program with only an FB, an input, and an output.

[Sequence program to which FB is pasted]

Create an FB in the following section.
Creating New Projects

This section explains how to create a new project by starting GX Works2.

Operating procedure

1. Select [Start] → [All Programs] → [MELSOFT Application] → [GX Works2] → [GX Works2].

2. After starting, the GX Works2 main screen is displayed.

Menu bar

Navigation window

Project view

Function Block Selection window

To the next page.
3. Select [Project] → [New].

4. The "New Project" dialog is displayed.

5. A project tree and the ladder screen are displayed.
Creating New Data

After a GX Works2 project is created, create a new data file ("Count_Num" is used as an FB name in this section).

Operating procedure

1. In the Navigation window, select "FB_Pool", and right-click and select [Add New Data] from the shortcut menu.

2. The "New Data" dialog is displayed.

   ① Select "Function Block".
   ② Input "Count_Num" as the FB name to be created.
   ③ Select "Ladder".
   ④ Click the OK button.

Point

When entering an FB name, be careful of the following points.
- Case-sensitive
- The maximum number of characters for a FB name is 32 in single-byte.

3. The newly created FB (Count_Num) is added to the Navigation window and the Function Block Selection window.

"Count_Num" is added.
### Setting Labels

Because FBs are utilized by being converting into components, the actual devices are not used and input labels, output labels, and internal labels are used to create a program.

First, categorize the actual devices of the sequence program into, input device, output device, and internal device.

Next, set each label for the categorized actual devices.

The labels corresponding to the actual devices in the FB that is to be created are as shown in the following tables.

<table>
<thead>
<tr>
<th>Device type</th>
<th>Device name</th>
<th>Label type (Class)</th>
<th>Label name</th>
<th>Data type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input device</td>
<td>X1</td>
<td>Input label (VAR_INPUT)</td>
<td>i_Count</td>
<td>bit</td>
</tr>
<tr>
<td>Output device</td>
<td>Y72</td>
<td>Output label (VAR_OUTPUT)</td>
<td>o_C_UP</td>
<td>bit</td>
</tr>
<tr>
<td>Internal device</td>
<td>D1</td>
<td>Internal label (VAR)</td>
<td>m_Cnt</td>
<td>word [signed]</td>
</tr>
</tbody>
</table>

Set the input label, output label, and internal label to be used in the FB in the following section.
Operating procedure

1. Double-click "Local Label" of the added FB and display the Function/FB Label Setting screen.

![Double-click "Local Label".]

2. The Function/FB Label Setting screen is displayed.

![Function/FB Label Setting screen.]

3. Set the labels as follows.

![Set the labels.]

Creating design data in Excel or other format in advance for the internal labels that are used normally, and entering the label by copying and pasting from the data, reduces the development man-hours.
Creating FB Programs

This section explains how to create a sequence program in an FB using the set labels.

Operating procedure

1. In the Navigation window, select "Project" → "POU" → "FB_Pool" → "Count_Num", and double-click "Program".

2. The [FB] Count_Num window is displayed.

3. Create an FB sequence program.

Sequence program of the FB to be created is described as follows.
Performing Conversion/Compilation

In order to operate an FB, a conversion/compilation process is required. This section explains how to convert/compile all programs.

Operating procedure

1. Select [Compile] → [Rebuild All].

2. The following message is displayed.

3. All programs are converted/compiled and the result is displayed in the Output window.

This completes the creation of a new FB.

For details of the procedures to use the created FBs, refer to the section '(3) Pasting FBs' in 'Using FB Libraries' onward.

Point

When pasting multiple FBs, which describe the device output (such as OUT Y0Z9) by using index modification internally, duplicate coil warnings occur while compiling. However, this is not a usage problem.
The sequence program created by pasting the created FB is as follows.

When the input (X1) is turned ON 12 times,

The output (Y12) is turned ON.
Protecting Created FBs

A created FB can be protected by setting up a block password. Outflow of technological know-how can be prevented by using a password, as the protection using a password disables opening of programs in the FB.

This section explains how to set up a block password for the created FB.

**Caution**

If you forget the password, you cannot open the program in the FB.
Do not lose the password.

**Operating procedure**

1. In the Navigation window, select [Project] → [POU] → [FB_Pool] → [Count_Num].

   ① Right-click the created FB "Count_Num".

   ② Select **Block Password**.

2. The "Set Block Password" dialog is displayed.

   ① Click the **Password Setting** button.

   To the next page
3. The "Change Block Password" dialog is displayed.

4. The block password is set to "Count_Num".

- Locking an FB by using a block password is activated when the project is re-opened.
- The FBs for which the block passwords were set are displayed in the Project view as follows.
- A block password can be changed by resetting the password. In this case, unlock the password prior to change.
Utilizing FBs in Other Projects

FBs can be utilized in other projects.

When utilizing FBs in other projects, open the source and the destination projects respectively, and copy the FBs from the source project to the destination project.

This section explains how to use FBs in other projects by using the FB "Count_Num" created in this Quick start guide as an example.

Operating procedure

1. Start another GX Works2, and open the project in which the FB "Count_Num" is utilized.

2. Drag and drop the FB "Count_Num" to the "FB_Pool" icon of the destination project.
3. The FB "Count_Num" is copied to the destination project.

Point

- If the programmable controller types of the source project and the destination project are different, copying FBs will not be possible.
- FBs created in GX Developer can also be utilized in the GX Works2 projects.

Use the following procedure to copy FBs.

1. Open the GX Developer source project with GX Works2.
   Select [Project] → [Open Other Data] → [Open Other Project].
   (For details, refer to the GX Works2 Version 1 Operating Manual (Common).)
2. Start another GX Works2, and open the destination project.
3. Drag and drop the FB from the source project to the destination project.
Techniques for Creating FBs

This section introduces techniques for creating FB sequence programs.

1. To transfer multiple bits to a word label

Multiple bits can be transferred to a word label by using BSET and BRST instructions and setting up ON/OFF information for each bit of the target word.

2. To refer to multiple consecutive data in FBs

Continuous domain of the input and output labels of an FB can be imported to the FB internal label by the following method.

An example of an input label is explained below.

(1) Store values on D register from D1000 up to n point in the main program.
(2) Specify D1000 to the FB input label.
(3) In the FB, transfer to BMOV internal label from the input label (i_Write_Data) up to n point (required to secure arrays for up to n point).

In this case, however, if the input and output labels of the FB are omitted, an unexpected data file will be stored in the internal label, resulting unintentional operations such as overrun of a sequence program. Never omit the input and output labels.
3. To use index registers in an FB

When using index registers in an FB, add a save program and restore program for the index registers to protect them.

[Example of creation]
The following shows an example of saving index registers Z7, Z8, and Z9 in the FB prior to executing a program and restoring the index that will be saved at the time when the program is end.

<table>
<thead>
<tr>
<th>Label name</th>
<th>Type</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>int_Z_tmp[0]</td>
<td>bit</td>
<td>For saving index register Z9</td>
</tr>
<tr>
<td>int_Z_tmp[1]</td>
<td>bit</td>
<td>For saving index register Z8</td>
</tr>
</tbody>
</table>

```
FB_END

[MOV Z8 int_Z_tmp[0]]

[MOV Z8 int_Z_tmp[1]]

[MOV Z8 int_Z_tmp[2]]

FB_END

[MOV int_Z_tmp[0] Z8]

[MOV int_Z_tmp[1] Z8]

```
Excel is a registered trademark of Microsoft Corporation in the United States and other countries. Ethernet is a registered trademark of Xerox Corporation. All other company names and product names used in this guide are trademarks or registered trademarks of their respective companies.

Precautions before use
This publication explains the typical features and functions of the products herein and does not provide restrictions and other information related to usage and module combinations. Before using the products, always read the product user manuals. Mitsubishi Electric will not be held liable for damage caused by factors found not to be the cause of Mitsubishi Electric; opportunity loss or lost profits caused by faults in Mitsubishi Electric products; damage, secondary damage, or accident compensation, whether foreseeable or not, caused by special factors; damage to products other than Mitsubishi Electric products; and to other duties.

For safe use
- To use the products given in this publication properly, always read the relevant manuals before use.
- The products have been manufactured as general-purpose parts for general industries, and have not been designed or manufactured to be incorporated in a device or system used in purposes related to human life.
- Before using the products for special purposes such as nuclear power, electric power, aerospace, medicine or passenger movement vehicles, consult with Mitsubishi.
- The products have been manufactured under strict quality control. However, when installing the products where major accidents or losses could occur if the products fail, install appropriate backup or fail-safe functions in the system.
Mitsubishi iQ Platform Compatible Programmable Controller Engineering Software
MELSOFT GX Works2 FB Quick Start Guide

Country/Region | Sales office | Tel/Fax
--- | --- | ---
USA | MITSUBISHI ELECTRIC AUTOMATION, INC. 500 Corporate Woods Parkway, Vernon Hills, IL 60061, U.S.A. | Tel: +1-847-478-2100 Fax: +1-847-478-2253
Mexico | MITSUBISHI ELECTRIC AUTOMATION, INC. Mexico Branch Mariano Escobedo #59, Col. Zona Industrial, Tlahualapa Edo, CP54030, Mexico | Tel: +52-55-3067-7500
Brazil | MITSUBISHI ELECTRIC DO BRASIL COMERCIO E SERVICOS LTDA. Rua Jussara, 1750-Bloco B Anexo, Jardim Santa Cecilia, CEP 06465-070, Barueri-SP, Brasil | Tel: +55-11-4689-3000 Fax: +55-11-4689-3016
Germany | MITSUBISHI ELECTRIC EUROPE B.V. German Branch Gothaer Strasse 8, D-04080 Ratingen, Germany | Tel: +49-2102-866-0 Fax: +49-2102-866-1120
UK | MITSUBISHI ELECTRIC EUROPE B.V. UK Branch Travellers Lane, Hatfield, Hertfordshire, AL10 8BX, U.K. | Tel: +44-1707-28-8780 Fax: +44-1707-27-8695
Ireland | MITSUBISHI ELECTRIC EUROPE B.V. Irish Branch Westgate Business Park, Ballymount, IRL-Dublin 24, Ireland | Tel: +353-1-4198800 Fax: +353-1-4198900
Italy | MITSUBISHI ELECTRIC EUROPE B.V. Italian Branch Centro Direzionale Colonne-Palazzo Siro Viale Colonne 7, 20864 Agrate Brianza(Milano) Italy | Tel: +39-039-60531 Fax: +39-039-6053312
Spain | MITSUBISHI ELECTRIC EUROPE B.V. Spanish Branch Carretera de Rubí, 76-80-Apto. 420, 08173 Sant Cugat del Vallés (Barcelona), Spain | Tel: +34-935-65-3131 Fax: +34-935-85-1579
France | MITSUBISHI ELECTRIC EUROPE B.V. French Branch 25, Boulevard des Bouvets, F-92741 Nanterre Cedex, France | Tel: +33-1-55-68-55-68 Fax: +33-1-55-68-57-57
Czech Republic | MITSUBISHI ELECTRIC EUROPE B.V. Czech Branch Avenir Business Park, Radlicka /711/113e, 158 00 Praha 5, Czech Republic | Tel: +420-251-551-470 Fax: +420-251-551-471
Polan | MITSUBISHI ELECTRIC EUROPE B.V. Polish Branch ul. Krakowska 50, 32-083 Balice, Poland | Tel: +48-12-630-47-00 Fax: +48-12-630-47-01
Sweden | MITSUBISHI ELECTRIC EUROPE B.V. (Scandinavia) Fjällvägen 8, SE-22736 Lund, Sweden | Tel: +46-8-625-10-00 Fax: +46-46-39-70-18
Russia | MITSUBISHI ELECTRIC EUROPE B.V. Russian Branch St. Petersburg office Piskarevsky pr. 2, bl 2, Lt "Sch", BC "Benia", office 720; RU-195027 St. Petersburg, Russia | Tel: +7-812-633-3497 Fax: +7-812-633-3499
Turkey | MITSUBISHI ELECTRIC TURKEY A.S. Yukarı Boyanlı Branch Sentafi Mahallesi: Nuruk Sokak No.5, TR-34775 Umurcan, İstanbul, Turkey | Tel: +90-216-526-3990 Fax: +90-216-526-3995
Dubai | MITSUBISHI ELECTRIC EUROPE B.V. Dubai Branch Dubai Silicon Oasis, P.O. BOX 341241, Dubai, U.A.E. | Tel: +971-4-3724716 Fax: +971-4-3724721
South Africa | ADROIT TECHNOLOGIES 20 Waterford Office Park, 189 Witkoppen Road, Fourways, Johannesburg, South Africa | Tel: +27-11-658-8100 Fax: +27-11-658-8101
China | MITSUBISHI ELECTRIC AUTOMATION (CHINA) LTD. No.1386 Hangqiao Road, Mitsubishi Electric Automation Center, Shanghai, China | Tel: +86-21-2322-3030 Fax: +86-21-2322-3000
Taiwan | SETSUYO ENTERPRISE CO., LTD. 6F, No. 105, Wugong 3rd Road, Wugou District, New Taipei City 24889, Taiwan, R.O.C. | Tel: +886-2-2259-2499 Fax: +886-2-2259-2509
Korea | MITSUBISHI ELECTRIC CORPORATION KOREA CO., LTD. 7F-9F, Gangseo Hangang Xi-tower A, 401, Yangcheon-ro, Gangseo-Gu, Seoul 157-801, Korea | Tel: +82-2-386-9310 Fax: +82-2-3864-8372
Singapore | MITSUBISHI ELECTRIC ASIA PTE. LTD. 307, Alexandra Road, Mitsubishi Electric Building, Singapore 159943 | Tel: +65-6473-2308 Fax: +65-6476-7439
Thailand | MITSUBISHI ELECTRIC FACTORY AUTOMATION (THAILAND) CO., LTD. 12th Floor, SVCity Building, Office Tower 1, 106, 899/19 and 20 Rama 3 Road, Kwaeng Bangrangpong, Khet Yawanna, Bangkok 10120, Thailand | Tel: +66-2828-5282 Fax: +66-2828-6020
Vietnam | MITSUBISHI ELECTRIC VIETNAM COMPANY LIMITED Hanoi Branch 6-Floor, Detoch Tower, 8 Ton That Hue Street, My Dinh 2 Ward, Nam Tu Liem District, Hanoi, Vietnam | Tel: +84-4-3937-8075 Fax: +84-4-3937-8076
India | PT. MITSUBISHI ELECTRIC INDONESIA Gedung Jaya 11th Floor, Jl. MH Thamrin No.12, Jakarta Pusat 10340, Indonesia | Tel: +62-21-3152-4661 Fax: +62-21-3152-3842
India | MITSUBISHI ELECTRIC INDIA PVT. LTD. Pune Branch Emerald House, El-3, J Block, M.I.D.C Bhosari, Pune-411016, Maharashtra, India | Tel: +91-20-2710-2000 Fax: +91-20-2710-2100
Australia | MITSUBISHI ELECTRIC AUSTRALIA PTY LTD. 348 Victoria Road, P.O. Box 11, Rydalmere, N.S.W 2116, Australia | Tel: +61-2-9864-7777 Fax: +61-2-9864-7245

Mitsubishi Electric Corporation, Nagoya Works is a factory certified for ISO 14001 (standards for environmental management systems) and ISO 9001 (standard for quality assurance management systems).

ISO 14001
ISO 9001

MITSUBISHI ELECTRIC CORPORATION
HEAD OFFICE: TOKYO BUIrDINg, 2-7-1, MARUNOUCHI, CHIHOoDA-AU, TOKYO 100-8310, JAPAN
NAGOYA WORKS: 1-1-4, YACHI-MINAMI, HIGASHI-NAGOYA, NAGOYA, JAPAN

New publication effective Aug, 2011.
Specifications subject to change without notice.