Programmable Controller
MELSEC-L Series Quick Start Guide

Let's Start, L Series!

Little on size, large on performance
The new L series has a small footprint and is loaded with features.
How to read this guide

The following shows the symbols used in this Quick start guide with descriptions and examples.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Point" /></td>
<td>This symbol explains information you need to know.</td>
<td>Select [View] → [Comment] (<code>Ctrl</code> key + <code>F5</code> key). The comment display/hide setting can be switched.</td>
</tr>
<tr>
<td><img src="image" alt="Reference" /></td>
<td>This symbol describes the references of manuals and pages for more details.</td>
<td>For details, refer to the following manual. MELSEC-L CPU Module User's Manual (Function Explanation, Program Fundamentals) : SH-080889ENG</td>
</tr>
<tr>
<td><img src="image" alt="Terminology" /></td>
<td>This symbol describes the explanations of the terminology.</td>
<td>Device : A place where ON/OFF or numeric values and character string data is recorded in the programmable controller.</td>
</tr>
<tr>
<td><img src="image" alt="Caution" /></td>
<td>This symbol describes content that must be noted in operation.</td>
<td>When mounting the module, the power must be turned off.</td>
</tr>
<tr>
<td><img src="image" alt="Menu" /></td>
<td>Menu names on the menu bar ([ ] → [ ] shows drop-down menus.)</td>
<td>Select [Project] → [New project].</td>
</tr>
<tr>
<td><img src="image" alt="Buttons" /></td>
<td>Buttons on the screen</td>
<td><img src="image" alt="OK" /> button</td>
</tr>
<tr>
<td><img src="image" alt="Keys" /></td>
<td>Keys on the keyboard</td>
<td><code>F4</code> key</td>
</tr>
<tr>
<td><img src="image" alt="Another Procedure" /></td>
<td>Another procedure corresponding to a drop-down menu (icons and keys on the keyboard)</td>
<td>Select [View] → [Comment] (<code>Ctrl</code> key + <code>F5</code> key).</td>
</tr>
</tbody>
</table>
Introduction

This Quick start guide explains the basic procedures for the first-time use of the Mitsubishi programmable controller MELSEC-L series CPU module (CPU module).

You can easily understand how to use the programmable controller with this guide.

Reference

● Precautions

Read "SAFETY PRECAUTIONS" in the MELSEC-L CPU Module User's Manual or "Safety Guidelines" that is an included manual of CPU module carefully.

Caution

This Quick start guide explains operations in the programmable controller system described in "System Configuration" (P.9).

Read the manuals referred on the following page when you design or manage the system.

"Related manuals" (P.6)
Operations that can be performed using MELSEC-L series

■ Programmable controllers

The programmable controllers perform sequence control and logical operations by switching the output of output equipment ON/OFF according to the command signal from the input equipment.

Other equipment is shown below.

<Examples of input equipment>

<Examples of output equipment>

### Terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sequence control</td>
<td>Consecutively processes each control step based on the fixed order or procedure.</td>
</tr>
<tr>
<td>Logical operations</td>
<td>One of the basic operation methods in programming. Logical operations consist of three basic operations: logical AND, logical OR, and logical NOT.</td>
</tr>
<tr>
<td>Limit switch</td>
<td>A switch to stop the movement of mobile objects on both sides of a moving apparatus for safety reasons.</td>
</tr>
<tr>
<td>Relay</td>
<td>Breaks/connects the electricity with electrical switching.</td>
</tr>
<tr>
<td>Contactor</td>
<td>Generally called an electromagnetic contactor to break circuits and switch the heater.</td>
</tr>
<tr>
<td>Solenoid valve</td>
<td>An electromagnet with a direct/alternating current. Connected to the output side of the programmable controller.</td>
</tr>
</tbody>
</table>
Features of CPU module

MELSEC-L series programmable controllers are all-in-one programmable controllers that have the following functions built into the CPU module. The use of these built-in functions enables you to design a smaller-scale system.

**Built-in Ethernet function**
A maximum of 16 external devices can be connected via a hub. The reading/writing of the device data of the CPU module and the sending/receiving of the data of the other connected devices can be performed to/from a personal computer and GOT.

**Built-in I/O function**
Single function exclusive modules become unnecessary, and a smaller-scale system can be configured using only LCPU. Therefore, system cost reduction can be realized.

**Data logging function**
Logging can be performed under various conditions using the exclusive configuration tools. The collected data can be saved to the SD memory card in the CSV format.

**Built-in CC-Link function**
I/O modules, intelligent function modules, and special function modules, which are arranged separately, can be controlled with the CPU module. In addition, a simple separately-configured system can be designed by connecting multiple CPU modules using CC-Link. *CC-Link function is only built into L26CPU-BT.*

* The illustration represents L26CPU-BT.
System enhancement according to application

By connecting various types of modules, the system can be enhanced according to the application. As a baseless structure is employed, the space of the control panel can be used effectively without being limited by the size of the base.

RS-232 adapter (optional)
Attached when connecting to GOT.
(Hardware Design, Maintenance and Inspection): SH-080890ENG

Display unit (optional)
The system status can be confirmed and the system setting values can be changed by attaching this to the CPU module.

END cover
Provided with the CPU module. Be sure to connect an END cover on the right of the terminal module.
(Hardware Design, Maintenance and Inspection) : SH-080890ENG

Power supply module
RS-232 adapter
CPU module
I/O module or intelligent function module
END cover

Display unit
USB connection

SD memory card
GX Works2

SD memory card (optional)
Using an SD memory card enables the following functions to be used.
- Data logging function
- Boot operation via the SD memory card
- Backing up data to the SD memory card
- Restoring backup data
(Function Explanation, Program Fundamentals) : SH-080899ENG
*MELSEC-L CPU Module User's Manual (Data logging functions) : SH-080893ENG

GX Works2
This is a programming tool to design, debug, and maintain sequence programs on a Windows personal computer.
GX Works2 Version 1 Operating Manual (Common) : SH-080779ENG
Programs can also be created effectively using FB (Function Block).
*Mitsubishi integrated FA software
MELSOFT GX Works2 FB Quick start guide : L08182ENG

I/O module or intelligent function module
The following modules can be attached as required.
- I/O modules
- Analog I/O modules
- Serial communication modules
*Mitsubishi integrated FA software
Manual for each module

* The illustration represents an L02CPU CPU module.
Related manuals

This Quick start guide explains the basic procedures for introducing programmable controllers. Read the following manuals to use each module with a full understanding according to your purpose.

■ Learning about programmable controllers

  (Hardware Design, Maintenance and Inspection) ................................................ SH-080890ENG
  This manual explains specifications, installation, and maintenance methods for the CPU module and the power supply module.

- MELSEC-L CPU Module User’s Manual
  (Function Explanation, Program Fundamentals) .................................................. SH-080889ENG
  This manual explains the functions of the CPU modules.
  It also explains the operations of devices, parameters, and display unit that are the basic knowledge necessary for programming.

■ Learning about programming tools (software)

- GX Works2 Beginner’s Manual (Simple Project) ................................................ SH-080787ENG
  This manual explains the basic operations for creating, editing, and monitoring programs on simple projects for operators who are using GX Works2 for the first time.

- GX Works2 Version 1 Operating Manual (Common) ........................................... SH-080779ENG
  This manual explains the common functions of both the simple and structured projects of GX Works2, including the operation methods for system configurations, parameter settings, and online functions.
Using programmable controllers

The programmable controllers are installed with procedures as shown below.

1. **Preparing for Operation** (P.8)
   Preparing the necessary equipment

2. **System Configuration** (P.9)
   Introducing equipment used for operations in this Quick start guide

3. **Mounting Modules** (P.10)
   Mounting the prepared modules

4. **Wiring Modules** (P.12)
   Wiring the power supply module and the external I/O devices

5. **Checking Power Supply** (P.15)
   Turning on the system to check the condition of the CPU module

6. **Programming** (P.16)
   Creating a program with GX Works2

7. **Writing Programs** (P.22)
   Writing a program created with GX Works2 to the CPU module

8. **Checking Operation** (P.25)
   Executing the program by turning the CPU module to RUN and checking that ON/OFF of inputs correspond to ON/OFF of output
Preparing for Operation

Preparing the necessary equipment

- Programmable controller
- Personal computer
- GX Works2 Version 1
- USB cable
- Lamp
- Switch
- A6CON1
- External power supply
- DIN rail (Including DIN rail stopper)

* GX Works2 Version 1 needs to be installed in your personal computer in advance.
System Configuration

System configuration example

This Quick start guide explains the following system configuration as an example. Inputs and outputs are configured as switches and lamps respectively.

* Wires to the power supply module and the power of the external I/O devices are omitted.

<table>
<thead>
<tr>
<th>No.</th>
<th>Name</th>
<th>Model</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>①</td>
<td>Power supply module</td>
<td>L61P</td>
<td>Supplies power to modules such as CPU module.</td>
</tr>
<tr>
<td>②</td>
<td>CPU module</td>
<td>L02CPU</td>
<td>Integrates the control of the programmable controller.</td>
</tr>
<tr>
<td>③</td>
<td>END cover</td>
<td>L6EC</td>
<td>Supplied with the CPU module. Be sure to connect an END cover on the right of the terminal module.</td>
</tr>
<tr>
<td>④</td>
<td>Connection cable (USB cable)</td>
<td>MR-J3USBCBL3M (USB A type - USB mini B type)</td>
<td>Connects the personal computer with GX Works2 installed and the CPU module.</td>
</tr>
<tr>
<td>⑤</td>
<td>DIN rail</td>
<td>(IEC 60715)</td>
<td>The programmable controller system is secured by attaching it to the DIN rail.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• TH35-7.5Fe</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• TH35-7.5Al</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• TH35-15Fe</td>
<td></td>
</tr>
<tr>
<td>⑥</td>
<td>DIN rail stopper</td>
<td>–</td>
<td>Use DIN rail stoppers that can be attached to the DIN rails.</td>
</tr>
<tr>
<td>⑦</td>
<td>External power supply</td>
<td>–</td>
<td>Supplies power to the external I/O devices. Use the CE marked models and be sure to perform grounding for the FG terminal.</td>
</tr>
</tbody>
</table>
Mounting Modules

Mount the prepared modules.

A battery connector must be connected when using the CPU module for the first time.

**Caution**

The power supply must be disconnected when mounting modules.

Mounting modules

1. Release the module joint levers located on the top and bottom of the CPU module. (Slide them towards the front of the module.)
2. Install the modules by inserting the connectors of the CPU module and the power supply module straight so that they can be engaged.
3. Lock the module joint levers located on the top and bottom of the CPU module. (Slide them towards the back of the module.)
4. to 6. Using the same procedure, attach the END cover.

Complete

**Point**

- Connect a battery in the CPU module by the following procedure.

1. Open the cover at the bottom of the CPU module.
2. Confirm the directions of the connectors, and insert the battery side connector into the CPU module side connector.
3. Close the cover at the bottom of the CPU module.

Complete
Mounting Modules to DIN Rail

1. Pull down all the DIN rail hooks on the back of the modules. (Pull them down until they click.)

2. Engage the claws at the top of the modules with the top of the DIN rail, and then insert the DIN rail to install.

3. Lock the DIN rail hooks of the modules to engage them with the DIN rail. (Push them up until they click. If your finger does not reach the DIN rail hook, use a screwdriver, etc.)

4. Loosen the screws of the DIN rail stoppers.

5. Engage the claw at the bottom of a DIN rail stopper with the bottom of the DIN rail, and then engage the claw at the top of the DIN rail stopper with the top of the DIN rail. (Engage the DIN rail stopper after confirming the arrow indication on the front surface of the DIN rail stopper.)

6. Slide the DIN rail stopper to the edge of the module and tighten the screw using a screwdriver. (Using the same procedure, attach a DIN rail stopper to other side of the module.)
Wiring Modules

Wire the power supply module and the external I/O devices.

⚠️ Caution

The power supply must be disconnected when wiring modules.

Reference

For details of wiring precautions, refer to the following manual.

MELSEC-L CPU Module User’s Manual (Hardware Design, Maintenance and Inspection) : SH-080890ENG

Wiring the power supply module

The following shows an example of wiring the power line and the ground wire. Grounding is performed to prevent electric shocks and malfunctions.

1. Connect the 100VAC power supply to the power input terminals via the breakers and the isolation transformers.

2. Connect the LG and FG terminals to the ground.
Wiring connector for external devices

The following shows an example of wiring the connectors for external devices.

Caution

The pin arrangements of the connectors for external devices differ considerably from those of the I/O modules. Be sure to confirm the flat cable arrangement in the illustration shown above before connection.
Wire the power supply lines for the I/O equipment and the programmable controller separately as shown below.

**Terminology**

**Isolation transformer**: A two-winding transformer. The primary and secondary coils are wound separately to protect the secondary load.

**Control panel**: This is a panel that consists of breakers, switches, protection devices, relays, and programmable controllers, etc. By combining them, the panel performs the following operation.

- Receiving signals from external switches and sensors
- Suppling electricity to operate motors and solenoid valves of external machines and equipment
- Giving the signals to other equipment.
5 Checking Power Supply

Check that the power supply runs normally after configuring the system, mounting modules, and wiring.

**Operating procedure**

1. Check before turning on the power supply.
   - Wiring of the power supply
   - Power supply voltage

2. Set the CPU module to STOP.
   Open the cover on the front of the CPU module and set the switch to STOP.

3. Turn on the power supply module.

4. Check that the power supply runs normally.

Check the front LEDs on each module.
The following shows the normal state of the LEDs.

- Power supply module: "POWER" LED lights in green.
- CPU module: "MODE" LED lights in green.

When a parameter or program is not written to the CPU module, the "ERR." LED flashes red, but it is not a problem at this stage.
The LED goes off when a program is written.

"Writing Programs" (P.22)

---

**Point**

- If the "POWER" LED of the power supply module is off, even though the power is turned on, check the wiring and installation statuses to confirm whether or not they are correct.
- If the "BAT." LED of the CPU module is flashing, check whether the battery has been correctly connected.

---

**Terminology**

Parameter: Setup information necessary to operate the programmable controller system. Modules and the network are set by writing parameters to the CPU module.

---

Construction of the system is complete.
Turn off the power supply.
6 Programming

Create a program (sequence program) for sequence control.

■ "Devices" and "Instruction symbols" in programming

Combine "Devices" and "Instruction symbols" to create a sequence program.

1. Devices

Devices include bit devices and word devices.

1. Bit device: Handles one-bit information such as the ON/OFF of a switch or a lamp.

- ON/OFF of a switch
- ON/OFF of a lamp

Examples of bit devices

<table>
<thead>
<tr>
<th>Device name</th>
<th>Device symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>X</td>
<td>Receives a signal from an external device such as a switch.</td>
</tr>
<tr>
<td>Output</td>
<td>Y</td>
<td>Outputs a signal to an external device such as a lamp.</td>
</tr>
<tr>
<td>Internal relay</td>
<td>M</td>
<td>Temporarily saves data status in programs.</td>
</tr>
<tr>
<td>Timer (contact)</td>
<td>T</td>
<td>Used to measure time. (When the set time comes, the contact is set to ON.)</td>
</tr>
<tr>
<td>Counter (contact)</td>
<td>C</td>
<td>Used to count the number of times the input condition turns from OFF to ON.</td>
</tr>
</tbody>
</table>

2. Word device: Handles 16-bit information such as numeric values and character strings.

Examples of word devices

<table>
<thead>
<tr>
<th>Device name</th>
<th>Device symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data register</td>
<td>D</td>
<td>Registers numeric values and character strings.</td>
</tr>
<tr>
<td>Timer (current value)</td>
<td>T</td>
<td>Used to measure time. (Stores the current value of measuring time.)</td>
</tr>
<tr>
<td>Counter (current value)</td>
<td>C</td>
<td>Used to count the number of times the input condition turns from OFF to ON.</td>
</tr>
</tbody>
</table>

Terminology

Device: A location to store data such as ON/OFF, numeric values, and character strings in the programmable controller.

Internal relay: Breaks/connects the sequential circuit by switching ON/OFF.

Contact: An input used when creating a sequence program.
2. Instruction symbols

The following shows the basic instructions of sequence control.

<table>
<thead>
<tr>
<th>Instruction symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[ ]</td>
<td>Open contact: Conducts when an input signal is set to ON.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Closed contact: Conducts when an input signal is set to OFF.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Coil output: Outputs data to a specified device.</td>
</tr>
</tbody>
</table>

**Terminology**

Coil : An output used when creating a sequence program.

**Reference**

This section explains the most basic devices and instructions. In addition to those listed above, other devices and instructions convenient for sequence control are available.

MELSEC-Q/L Programming Manual (Common Instructions):SH-080809ENG

**Creating a program**

Create a sequence program for rehearsal.

The following shows how to create a sequence program with basic devices and instruction symbols for sequence control.

The following devices and instruction symbols are used.
- Input : "X" device
- Output : "Y" device
- Instruction symbols : [ ] , [ ] , [ ]

Create a program that performs the following controls.
- When the X6 and X7 switches are turned on, the Y0 output lamp turns on.
- When the X8 switch is turned on, the Y6 and Y7 output lamps turn off.

The following explains the procedure to create this sequence program.
## Starting GX Works2

### Operating procedure

1. Select [Start] → [All Programs] → [MELSOFT Application] → [GX Works2] → [GX Works2].

After starting, the GX Works2 main screen is displayed.

## Creating a new project

A project consists of programs, device comments, and parameters.

### Operating procedure

1. Select [Project] → [New...].

A project tree and a ladder screen are displayed.

2. Select "LCPU".

3. Select the LCPU to be used (L02 in this guide).

4. Click the OK button.
Creating a sequence program

Operating procedure

1. Enter $X_6$.
   ① Click the area to enter, and then enter "X".
   ② Enter "6" on the ladder input screen, and then click the button.

2. Enter $X_7$.
   ① Click the area to enter, and then enter "X".
   ② Enter "7" on the ladder input screen, and then click the button.

3. Enter $Y_0$.
   ① Enter "Y".
   ② Enter "0" on the ladder input screen, and then click the button.

4. Enter $X_8$.
   ① Click
   ② Enter device "X8", and then click the button.

5. Enter $Y_6$.
   ① Enter "Y".
   ② Enter "6" on the ladder input screen, and then click the button.
Coil Y6 is displayed.

6. Draw a line.

① Click the area to enter, and then enter Ctrl + and Ctrl + .

Coil Y7 is displayed.

7. Enter <Y7>.

① Enter “Y”.
② Enter “7” on the ladder input screen, and then click the OK button.

The ladder is left-aligned.

■ Converting a program

Define the contents of the entered ladder block.

Operating procedure

① Select [Compile] → [Build].

Perform the conversion to align entered ladders. When completed, the gray display turns to white.

[Before conversion]

[After conversion]

The programming is completed.

Point

Lines can also be edited using the following short-cut keys.

<table>
<thead>
<tr>
<th>Editing</th>
<th>Toolbar</th>
<th>Short-cut key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing lines</td>
<td>F10</td>
<td></td>
</tr>
<tr>
<td>Inputting vertical lines</td>
<td></td>
<td>Shift + F9</td>
</tr>
<tr>
<td>Inputting horizontal lines</td>
<td></td>
<td>Ctrl + F9</td>
</tr>
<tr>
<td>Inputting horizontal lines continually</td>
<td></td>
<td>Ctrl + Shift + F9</td>
</tr>
</tbody>
</table>
Saving a project

A program is saved in unit of project.
Save the created project with a name.

Operating procedure

① Select [Project] → [Save as].

The "Save the project with a new name" screen is displayed.

② Specify the save location.

③ Enter the work space name, project name, and title.

④ Click the save button.

⑤ Click the Yes button.

The project is saved.
Writing Programs

Write the program to the CPU module.

■ Connecting the CPU module and the personal computer

Connect the CPU module and the USB port of the personal computer with a USB cable.

■ Turning on the programmable controller

Turn on the power supply module. Then turn on the power of the external power supply.

■ Setting GX Works2 and the programmable controller connection

Operating procedure

1. Click [Connection Destination].
2. Double-click the data name to be transferred.

The "Transfer Setup Connection" screen is displayed.

3. Double-click "Serial USB".
4. Select "USB".
5. Click the [OK] button.

The "PC side I/F Serial setting" screen is displayed.

6. Click "PLC module".
7. Click "No Specification".
23

Click the button.

When properly connected, the connection completion message is displayed.

Click the button.

Click the button.

The connection setting is completed.

If the screen shown below is displayed after step 8 is performed, check that the USB driver has been installed correctly and that an appropriate connection cable (USB cable) is being used.

For the installation of the USB driver, refer to the following manual.

GX Works2 Installation Instructions: BCN-P5713

Point

If data such as programs and parameters are already stored in the CPU module, they are deleted. Thus the necessary data should be read from the CPU module and saved as a project before executing the Format PLC "Format PLC Memory" function.

Formatting the CPU module

Before writing the program, format the CPU module to set it to the initial status.

Operating procedure

1. Select [Online] → [PLC memory operation] → [Format PLC memory].

The "Format PLC memory" screen is displayed.

2. Select "Program Memory/Device Memory" from "Target Memory".

3. Click the button.

4. Click the button.

5. Click the button.

The CPU module format is completed.

Click the button to close the "Format PLC Memory" screen.

Point

If the screen shown below is displayed after step 8 is performed, check that the USB driver has been installed correctly and that an appropriate connection cable (USB cable) is being used.

For the installation of the USB driver, refer to the following manual.

GX Works2 Installation Instructions: BCN-P5713

Point

If data such as programs and parameters are already stored in the CPU module, they are deleted. Thus the necessary data should be read from the CPU module and saved as a project before executing the Format PLC "Format PLC Memory" function.
Writing programs to the CPU module

**Operating procedure**

1. Select [Online] → [Write to PLC].

   The "Online Data Operation" screen is displayed.

2. Click "Parameter + Program". "Program" and "Parameter" are checked.

3. Click the button.

   When the "Write to PLC" function is properly executed, the following message is displayed.

   4. Click the button.

   The program writing is completed.

   Click the button to close the "Online Data Operation" screen.
8 Checking Operation

Execute the program written to the CPU module to check the operation.
Check the program operation with the switches and lamps or the monitor function of GX Works2.

- Executing the program written to the CPU module

Use the "RESET/STOP/RUN" switch on the front of the CPU module for the operation.

[The usage of the RESET/STOP/RUN switch]
RUN : Executes the sequence program operation.
STOP : Stops the sequence program operation.
RESET : Performs the hardware reset, operation error reset, and operation initialization.

Operating procedure

1. Resetting the CPU module

① Tilt the "RESET/STOP/RUN" switch on the front of the CPU module towards "RESET". (for over a second)
[Resetting]
② After the "ERR." LED flashes, and the "ERR." LED and "MODE" LED turn OFF, release the switch.
[Resetting completed]
③ The switch returns to "STOP", and the resetting is completed.

Reference

If the "ERR." LED does not turn off, refer to the following manual.

MELSEC-L CPU Module User's Manual (Hardware Design, Maintenance and Inspection)
: SH-080890ENG
2. Executing the program

![Diagram of a control panel]

- **1.** Tilt the "RESET/STOP/RUN" switch on the front of the CPU module towards "RUN".
- **2.** If the "RUN" LED turns on green, the program is running normally.

**LED display during the STOP status**

- **MODE:** Green: ON
- **RUN:** OFF

**LED display during the RUN status**

- **MODE:** Green: ON
- **RUN:** Green: ON

**Caution**

Do not use pointed tools such as a screwdriver when operating the switch. They may damage the switch.

---

**Using switches and lamps to check the operation**

Check the program operation by turning the switches and lamps ON/OFF.

If all of the switches (X6, X7, and X8) are off right after the execution of the program, the output lamp Y0 stays off and the output lamp Y6 and the output lamp Y7 stay on due to the instructions from the created program.

1. **Operation check 1**
   - Turn on the switch X6. → The output lamp Y0 stays off and the output lamps Y6 and Y7 stay on.

2. **Operation check 2**
   - Turn on the switch X7. → The output lamp Y0 turns on.

3. **Operation check 3**
   - Turn on the switch X8. → The output lamps Y6 and Y7 turn off.
Checking the operation in GX Works2

Check the program operation by using the monitor mode on the GX Works2 screen, where switches and lamps can be operated and their statuses can be checked.

Operating procedure

1. Set the operating program display screen to the monitor mode.
   Select [Online] → [Monitor] → [Start Monitoring].

   Execute the monitor to display the "Monitor status" screen.

   The ON/OFF status of bit devices can be checked on the ladder screen.
   Contacts/outputs set to ON are displayed in blue.
   Right after the program execution, bit devices X8, Y6, and Y7 are lit in blue due to the instructions from the program.

2. Operation check 1
   ① Double-click X6 while pressing the Shift key → X6 turns on.

   ② Double-click X7 while pressing the Shift key → X7 turns on and Y0 lights.

3. Operation check 2

4. Operation check 3
   ③ Double-click X8 while pressing the Shift key → X8 turns off and Y6 and Y7 turn off.

While pressing the Shift key, double-click devices set to ON in Operation checks 1 and 2 to turn them off.
## Frequently-used functions

This section explains functions frequently used in GX Works2.

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clarifying programs</td>
<td>&lt;Comment&gt;</td>
<td>(P.29)</td>
</tr>
<tr>
<td></td>
<td>Device comment</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Statement</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Note</td>
<td></td>
</tr>
<tr>
<td>Monitoring device values and status</td>
<td>&lt;Device monitor&gt;</td>
<td>(P.34)</td>
</tr>
<tr>
<td></td>
<td>Device batch monitor</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Entry data monitor</td>
<td></td>
</tr>
<tr>
<td>Changing device values</td>
<td>&lt;Device test&gt;</td>
<td>(P.38)</td>
</tr>
<tr>
<td></td>
<td>Bit device forced ON/OFF</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Word device current value change</td>
<td></td>
</tr>
<tr>
<td>Changing running programs</td>
<td>&lt;Online program change&gt;</td>
<td>(P.41)</td>
</tr>
<tr>
<td>Checking errors</td>
<td>&lt;Error jump&gt;</td>
<td>(P.42)</td>
</tr>
<tr>
<td></td>
<td>PLC diagnostics</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Error jump</td>
<td></td>
</tr>
<tr>
<td>Monitoring system status</td>
<td>&lt;System monitor&gt;</td>
<td>(P.45)</td>
</tr>
</tbody>
</table>
Clarifying programs <Comment>

Use comments to clarify the contents of a program.

The following are the three types of comment.

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Number of characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device comment</td>
<td>Describes roles and usage of each device.</td>
<td>32</td>
</tr>
<tr>
<td>Statement</td>
<td>Describes roles and usage of ladder blocks.</td>
<td>64</td>
</tr>
<tr>
<td>Note</td>
<td>Describes roles and usage of output instructions.</td>
<td>32</td>
</tr>
</tbody>
</table>

**Point**

Select [View] → [Comment](Ctrl key + F5 key) to switch the comment display/hide setting.
Creating device comments

Device comments can be entered from the list or on the ladder diagram.

**<Input operation from the list>**

1. Double-click [Global Device Comment] in the project list.

2. Enter the start device number in "Device Name" and press the [Enter] key.

3. Enter a comment in the "Comment" column.
   * When entering comments for other devices, repeat Steps 2 and 3.

4. Click the [ ] button to close the screen.

**<Input operation on the ladder diagram>**

1. Select [Edit] → [Documentation] → [Device Comment].

2. Double-click the ladder symbol to enter a comment.

3. Enter a comment on the "Input DeviceComment" screen.

4. Click the [OK] button.

5. Select the [Device Comment] menu in Step 1 again to finish the operation.
Entering comments when creating ladders

1. Select [Tool] → [Options].

2. Select "Program Editor" → "Ladder" → "Device".

3. Select "Enter label comment and device comment".

4. Click the button.

After the ladder entry operation, the "Device Comment" screen is displayed and a comment can be entered.
Operating procedure

1. Select [Edit] → [Documentation] → [Statement].

2. Double-click a ladder symbol to enter a statement.

3. Select "In PLC".

4. Enter a statement.

5. Click the [OK] button.

6. Select the [Statement] menu in Step 1 again to finish the operation.

   If a statement is entered, the program needs to be "converted" to reflect the input. For details on the conversion, refer to the following.

   "Programming-Converting a program"(P.20)

Point

The following are the two types of statement.

- **PLC statement**
  Integrated statements can be written to/ read from the CPU module.

- **Peripheral statement**
  The program memory capacity can be saved since peripheral statements are not written to the CPU module. "***" is prefixed to the peripheral statement in the program.
Creating notes

Operating procedure

1. Select [Edit] → [Documentation] → [Note].

2. Double-click an output instruction to enter a note.

3. Select "In PLC".

4. Enter a note.

5. Click the [OK] button.

6. Select the [Note] menu in Step 1 again to finish the operation.

   If a note is entered, the program needs to be "converted" to reflect the input. For details on the conversion, refer to the following.

   Programming-Converting a program"(P.20)

The following are the two types of note.

● PLC note
   Integrated notes can be written to/read from the CPU module.

● Peripheral note
   The program memory capacity can be saved since peripheral notes are not written to the CPU module. "*" is prefixed to the peripheral note in the program.
The following are the two types of device monitor.

<table>
<thead>
<tr>
<th>Type</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device batch monitor</td>
<td>Used to monitor consecutive devices of one type.</td>
</tr>
<tr>
<td>Entry data monitor</td>
<td>Used to simultaneously monitor separately-located devices in the ladder or various devices on one screen.</td>
</tr>
</tbody>
</table>

### Device batch monitor

Monitors consecutive devices by specifying the start device number.

**Operating procedure**

1. Select [Online] → [Monitor] → [Device/Buffer memory batch].

2. Enter the start device number to be monitored and press the Enter key.

3. The values of devices and the ON/OFF status of contacts/coils are displayed.

4. Click the button to close the screen.
Entry data monitor

The device registration methods used to perform the Entry data monitoring are the specified device registration and the device registration with ladder monitor display. The device statuses can be displayed in watch windows 1 to 4.

<Specified device registration>

Register specified devices in Watch window 1.

1. Select [Online] → [Monitor] → [Start Monitoring].
2. Select [View] → [Docking Window] → [Watch1].
3. Double-click the "Device/Label" column.
4. Enter the device/label to be registered and press the Enter key.
5. Select [Online] → [Monitor] → [Start Watching].

* Watch window 1 is displayed on the bottom right of the screen.

The values of devices and the ON/OFF status of contacts/coils are displayed.
Specify the range of the ladder diagram on the ladder monitor screen and register the devices in a batch.

① Select [Online] → [Monitor] → [Start Monitoring].

② Select [View] → [Docking Window] → [Watch1].

③ Click the start point of the ladder.

④ Click the end point of the ladder while pressing the key → The range is specified.

⑤ Drag and drop the selected range to the watch window 1.

The values of the selected devices are monitored.

⑥ Select [Online] → [Monitor] → [Start Watching].

Register devices to the Watch window.
Installing the display unit allows you to monitor specified device memory values without using GX Works2.

**Operating procedure**

The following is an example of monitoring the Y6 value.

1. Select "function selection" screen > "CPU MON/TEST", and then click the ▶️ button.

2. Select "DEV MON/TEST", and then click the ▶️ button.

3. Click the ▼️ button on the screen shown below.

4. Select a device using ▲ or ▼️, and then click the OK button.

5. Move the cursor position using ◄ or ►️, and increase/decrease the value for each digit one number at a time to specify the device number using ▲ or ▼️, and then click the OK button.

The Y6 value is displayed.
Changing device values <Device test>

This function forcibly turns on/off the bit devices (X and Y) or changes the current value of the word device (such as T, C, and D).

### Forced ON/OFF of bit device

Turn on/off forcibly the bit device (X and Y) of the CPU module.

#### Operating procedure

1. Select [Online] → [Monitor] → [Start Monitoring].

2. Select [Debug] → [Forced Input Output Registration/Cancellation].

3. Enter a device to be turned on/off forcibly.

4. Turn on/off the device forcibly.

   - **[Resister FORCE ON]**: Turns on the device.
   - **[Resister FORCE OFF]**: Turns off the device.
   - **[Cancel Registration]**: Cancels the registration of the specified device.
Word device current value change

Changes the current value of the word device (such as T, C, and D) in the CPU module to the specified value.

**Operating procedure**

1. Select [Online] → [Monitor] → [Start Monitoring].

2. Select [Debug] → [Modify Value].

3. Enter the device number to be changed.

4. Enter the value to be changed.

5. Click the button.
Installing the display unit allows the forced ON/OFF of X/Y device with the operation of the display unit.

**Operating procedure**

The following is an example of operating the forced ON/OFF of X7.

1. Select "function selection" screen > "CPU MON/TEST", and then click the ▶ button.

2. Select "FORCED ON/OFF", and then click the ▶ button.

3. Select "SET ON/OFF", and then click the OK button.

4. Select X/Y using ▲ or ▼.

5. Move the cursor position using ▼ or ▲, and increase/decrease the value for each digit one number at a time to specify the device number using ▲ or ▼.

6. Move the cursor position using ▼ or ▲, switch ON/OFF using ▲ or ▼, and then click the OK button.
Changing running programs <Online program change>

This function writes only the modified ladder block to the CPU module while the CPU module is in the "RUN" status.
A program can be written in a short time since this function does not transfer the whole program.

The following is an example of adding a contact to the ladder.

Operating procedure

1. Display the ladder.

2. Add contacts.

3. Select [Compile] → [Online Program Change].

4. Click the Yes button.

When the online program change has been properly completed, the following message is displayed.

5. Click the OK button.

Caution

The program in the CPU module and the program to be modified in GX Works2 must be the same to perform the online program change. If you are not sure, verify the programs in advance or modify the ladder after performing the "Read from PLC" function.
Checking errors <Error jump>

If an error occurs, it can be checked with PLC diagnostics. By using the Error jump, you can jump to the step number of the sequence program corresponding to the error.

■ PLC diagnostics

The details of errors occurring can be checked from the PLC diagnostics.

Operating procedure

1. Select [Diagnostics] → [PLC diagnostics].

PLC diagnostics screen (example)

2. Click the [Error Help] button of the current error or the error history.

Help screen (example)

The details of the error and its countermeasures are displayed.
**Error jump**

Errors can be checked easily with the error jump function of PLC diagnostics.

**Operating procedure**

1. Select [Diagnostics] → [PLC diagnostics].

   ![](image1)

2. Click the [Error Jump] button.

   ![](image2)

   The cursor jumps to the step number of the sequence program corresponding to the selected error.
Installing the display unit allows you to confirm the errors occurring and errors which have occurred in the past with the display unit.

Operating procedure

The following is an example of the operating procedure to check the latest errors occurring in the CPU module.

1. Select "function selection" screen > "CPU MON/TEST", and then click the button.

2. Select "ERROR MONITOR", and then click the button.

3. Select "MONITOR", and then click the button.

Error information is displayed.

Error code is displayed.

Number of pages to be changed is displayed.

Error message is displayed.

Date of occurrence of error is displayed.

Time of occurrence of error is displayed.

Use or to display individual error information and common error information.

- To return to the previous screen, click the button.
- The error history can be displayed and "Clearing the errors", etc. can also be performed using the display unit.

Monitoring system status <System monitor>

This function monitors the system status of the CPU module and other modules.

Operating procedure

Select [Diagnostics] → [System Monitor].

The "System monitor" screen is displayed.

1. Main block
2. Operation to selected module
3. Connection channel list
4. Block information list
5. Module information list

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>①</td>
<td>Main block: Displays the module operation statuses and I/O addresses.</td>
</tr>
<tr>
<td>②</td>
<td>Operation to selected module: Displays the I/O and model of the module being selected.</td>
</tr>
<tr>
<td>③</td>
<td>Connection channel list: Displays the details of the connection target being set.</td>
</tr>
<tr>
<td>④</td>
<td>Block information list: Displays the block information.</td>
</tr>
<tr>
<td>⑤</td>
<td>Module information list: Displays the model, type, and start I/O of the module being selected.</td>
</tr>
</tbody>
</table>
● The details of each module can be checked from the "System Monitor" screen.

Double-click the CPU module.
→ The "PLC Diagnostics" screen is displayed and the operation status of the CPU module can be checked.

Double-click each module (excluding CPU and power supply).
→ The "Module Detailed Information" screen is displayed and the operation status of each module can be checked. The built-in I/O can also be checked.
Microsoft, Windows, Windows NT, and Windows Vista are registered trademarks or trademarks of Microsoft Corporation in the U.S. and other countries.
Ethernet is a trademark of Xerox Corporation in the U.S.
The SD and SDHC logos are trademarks.
Other corporate and product names in the manual may be trademarks or registered trademarks of their respective companies.

Precautions for Choosing the Products

This publication explains the typical features and functions of the L Series programmable controllers and does not provide restrictions and other information on usage and module combinations. When using the products, always read product user manuals.
Mitsubishi Electric will not be held liable for damage caused by factors found not to be the cause of Mitsubishi Electric; opportunity loss or lost profits caused by faults in Mitsubishi Electric products; damage, secondary damage, accident compensation caused by special factors unpredictable by Mitsubishi; damages to products other than Mitsubishi Electric products; and to other duties.

⚠️ For safe use

• To use the products given in this publication properly, always read the “manuals” before starting to use them.
• The products have been manufactured as general-purpose parts for general industries, and have not been designed or manufactured to be incorporated in a device or system used in purposes related to human life.
• Before using the products for special purposes such as nuclear power, electric power, aerospace, medicine or passenger movement vehicles, consult with Mitsubishi.
• The products have been manufactured under strict quality control. However, when installing the products where major accidents or losses could occur if the products fail, install appropriate backup or fail safe functions in the system.