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Introduction

This Quick Start Guide explains the basic procedures for first-time users of the high speed data logger 
module.

Precautions

Thoroughly read "SAFETY PRECAUTIONS" found in the QCPU User's Manual before using programmable 
controllers. Please pay careful attention to safety and handle the products properly.

Related manuals

The following manuals are related to the products introduced in this guide.

 High Speed Data Logger Module User's Manual.........................................................SH-080818ENG

 GX LogViewer Version1 Operating Manual .................................................................SH-080915ENG

 QCPU User's Manual (Hardware Design, Maintenance and Inspection).....................SH-080483ENG

 GX Developer Version8 Operating Manual..................................................................SH-080373E

 GX Works2 Version1 Operating Manual (Common) ....................................................SH-080779ENG

How to read this guide

The following table shows the symbols used in this guide with descriptions and examples.

Symbol Description Example

Remarks
When using the report creation function, the data 
logging file format must be set to "Binary file".

[   ]
Menu names on the menu bar

([   ] → [   ] indicates drop-down menus.)
Select [Online] → [Transfer Setup].

Buttons on the screen Click the  button.

Quick Start Guide
Functions of the high speed data logger module

Operation of the high speed data logger module

Logging data and creating reports

Remark
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Functions of the high speed data logger module

The high speed data logger module is a module that logs (records and saves) sampled programmable 
controller CPU data and saves them to a CompactFlash card as a file. Reports can be created from the logged 
file in Excel format.

Functions

'Data logging', 'Event logging', and 'Report' are the three major functions of the high speed data logger module.

The following are the two data logging methods:

High speed data logger module and relevant tools

The following are the relevant tools of high speed data logger module.

 'High Speed Data Logger Module Configuration Tool' to configure settings of high speed data logger module.

 'GX LogViewer' to display logged data.

Data logging : A function to log programmable controller CPU data at the specified data sampling interval.

Event logging : A function to monitor data sampled from the programmable controller CPU and log 
occurred events.

Report : A function to create reports with values and graphs obtained from data logging files and 
data sampled by the programmable controller CPU. The Excel layout for the report needs 
to be configured in advance.

Continuous logging : Continuously logs data at the specified data sampling interval, and creates data logging files.

Trigger logging : Logs data before and after the trigger occurrence (establishment of specified condition), 
and creates data logging files.

Logging

File

Report creation

Samples data 

from the CPU

Saves sampled data to the 

           CompactFlash card

Module

Logging

Report creation

High Speed Data Logger

Module Configuration Tool
Basic module setting

Logging setting

Report setting

GX LogViewer

Display logging data

in graph or list format.

CompactFlash

 card

Write the settings

Communicate

in real time

Save logging files to

a personal computer.

F
u
n
c
ti
o
n
s
 o

f 
th

e
 h

ig
h
 s

p
e
e
d
 

d
a
ta

 l
o
g
g
e
r 

m
o
d
u
le



3

Operation of the Operating high speed data logger module

Use this guide to understand the operation of the high speed data logger module by actually configuring the 
'trigger logging', 'continuous logging', and 'report' settings.

Descriptions in this guide

This section explains equipment used in this guide and the system configuration.

This section uses an example to explain the trigger logging 

function and how to confirm logged data.

This section uses an example to explain the continuous 

logging function and report creation.

Preparing for operation

Logging data before and after trigger occurrence

Creating reports from continuously logged data

Page Description

Introduced functionPage Description

Trigger logging

Continuous 

logging report

CASE 1

P7-

CASE 2

P16-

Preparation

P4-
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Preparing for operation

This section describes the preparation for operations instructed in CASE 1 and CASE 2.

1 Preparing equipment

Prepare the equipment and software needed in CASE 1 and CASE 2.

Items to prepare

In this guide, Excel 2003 or Excel 2007 is used in explanations.

STEP 1 Preparing equipment STEP 2 System configuration

Install a CompactFlash card to the 
high speed data logger module

Mount the 
modules onto 
the base unit.

Wire the power supply module.

Connect the high speed data 
logger module and the personal 
computer with the Ethernet cable.

Connect the CPU module and 
the personal computer with the cable.

High speed data logger module
<QD81DL96>

USB cable or RS-232C cable
(For connecting personal computer and 
programmable controller CPU module)

High Speed Data Logger
Module Configuration Tool

GX Works2 or GX Developer

Ethernet crossing cable
(For connecting personal computer and 

high speed data logger module)

[Q series] CPU module, 
power supply module, base unit

CompactFlash card
(QD81MEM-                BC)

Personal computer(Windows XP   */
Windows Vista  */Windows   7/

Windows  8/Windows  8.1/
Windows  10)

* Supported with 32-bit editions only

GX LogViewer Sample data for
Quick Start Guide 

Excel 2003/Excel 2007/
Excel 2010*/Excel 2013*/

Excel 2016*
* Supported with 32-bit editions only

High speed data logger module
<QD81DL96>

USB cable or RS-232C cable
(For connecting personal computer and 
programmable controller CPU module)

High Speed Data Logger
Module Configuration Tool

GX Works2 or GX Developer

Ethernet crossing cable
(For connecting personal computer and 

high speed data logger module)

[Q series] CPU module, 
power supply module, base unit

Excel 2003/Excel 2007/
Excel 2010*/Excel 2013*/

Excel 2016*
* Supported with 32-bit editions only

CompactFlash card
(QD81MEM-                BC)

Personal computer(Windows XP   */
Windows Vista  */Windows   7/

Windows  8/Windows  8.1/
Windows  10)

* Supported with 32-bit editions only

GX LogViewer Sample data for
Quick Start Guide 

Preparing High Speed Data Logger 
Module Configuration Tool

Preparing GX LogViewer Preparing sample data for 
the Quick Start Guide
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Preparing High Speed Data Logger Module Configuration Tool

For the acquisition of High Speed Data Logger Module Configuration Tool, contact your local Mitsubishi 
representative.

Please install the acquired tool.

Preparing GX LogViewer

For the acquisition of GX LogViewer, contact your local Mitsubishi representative.

Please install the acquired tool.

Preparing sample data for the Quick Start Guide

To obtain the sample data used in CASE 1 and CASE 2 in this guide, contact your local Mitsubishi 
representative.

Files included in sample data

• Sequence program (l08147eng-program_a): A GX Developer project file to be used in CASE 1 and CASE 2.

• Layout file (l08147eng-layout_a.xls): An Excel format file for report to be used in CASE 2.

• Logging result file (l08147eng-CASE1_a.CSV): A CSV file whose data are logged according to the 
procedure in CASE 1.
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2 System configuration

Configure the programmable controller system used in CASE 1 and CASE 2. 

2-1 Mounting and wiring modules

Follow the instructions in order from  to  .

2-2 Activating the system

 Power ON the power supply module.

 Write the sequence program (l08147eng-program_a) to the CPU module using GX Developer or GX 
Works2.

 Switch the mode of the CPU module to 'RUN'.

Precautions

The instructions in this guide are described according to the above programmable controller system 
configuration.

When designing and operating an actual system, read the manuals listed on the following page.

Related manuals (P. 1)

Install a CompactFlash card to the 
high speed data logger module.

Mount the 
modules onto 
the base unit.

Wire the power supply module.

Connect the high speed data 
logger module and the personal 
computer with the Ethernet cable.

Connect the CPU module and 
the personal computer with the cable.
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CASE 1 Logging data before and after trigger occurrence

This section explains how to perform the 'trigger logging' function using the equipment shown in the figure below 
as an example.

Figure

The following equipment is a winder for packaging film.

The sensor position moves up and down according to variation in the feeding reel speed, and a trigger (error) 
occurs when the allowable range is exceeded 100 lines (records) of data before and after the trigger 
occurrence are saved in a file.

Data logging settings

Operation flow

Target data : Feeding speed [D2003 (word [signed])], Winding speed [D2007 (word [signed])], 

Sensor position [D2005 (word [signed])]

Trigger condition : Sensor position   5, sensor position  -5

Data sampling interval : 0.1 second

Number of logging lines : 100 lines before trigger occurrence, 100 lines after trigger occurrence

Saved file format : CSV file

Feeding speed [D2003] Winding speed [D2007]

Winding reelFeeding reel

Sensor Sensor position [D2005]: Trigger condition

The sensor position moves up 

and down by the film slack.

STEP 1: Data logging settings 

                  (Trigger logging)

Configure the data logging settings 

using High Speed Data Logger 

Module Configuration Tool.

STEP 2: Write settings

Write the settings configured 

in STEP 1 to the high speed 

data logger module.

STEP 3: Graphical display of data

Display logged data in a graph 

using GX LogViewer and 

check the values.
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1 Data logging settings (Trigger logging)

Configure the settings to log the programmable controller CPU data before and after the establishment of a trigger 
condition.

1-1 Start High Speed Data Logger Module
Configuration Tool

1-2 Display the data logging setting screen

1-3 Select the logging type and the file format

1-4 Select the data sampling method

Select [MELSOFT Application] → [Logging Function]*1 →
[High Speed Data Logger Module Configuration Tool] from
"Start" of Windows®*2.
*1: Does not appear in Windows 8 or later.
*2: Select [All apps] in the Start screen or [Start] →
     [All Programs]/[All apps].

1 Click the  button.

2 Click the  button.

The wizard screen to configure the data logging settings is
displayed.

1 Select "Trigger logging" for the logging type, and "CSV

file" for the file format.

2 Click the  button.

1 Select "General sampling", and enter "0.1" for "Time

specification".

2 Click the  button.
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1-5 Set the target data

1-6 Configure the trigger settings

1 Specify the data to be logged.

Enter data as shown in the screen below.

Default values are automatically displayed for "Device" (Last),
"Access target CPU", "Data type", and "Output Format".

2 Click the  button.

1 Select "Compound conditions".

The trigger types are displayed.

2 Click the  button.

The OR combine (No.1) dialog box for specifying conditions is
displayed.

3 Specify the first trigger condition.

Enter data as shown in the screen below.

4 Click the  button.

The specified condition is added to the list of conditions.
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1-7 Set the number of logging lines

1-8 Configure the CSV output settings

5 Select the second line in the list of conditions, and click

the  button.

6 Specify the second trigger condition.

Enter data as shown in the screen below.

7 Click the  button.

The specified condition is added to the list of conditions.

8 Click the  button.

1 Enter "100" for "Before trigger", and "100" for "After

trigger".

2 Click the  button.

Use the default settings for the CSV output settings.

1 Click the  button.
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1-9 Configure the save settings

1-10 Enter the data logging name

1 Enter "Trigger_LOG" for the file save destination.

A folder with the name specified above is created on the
CompactFlash card.

2 Select "Trigger logging unit" for the file switching timing.

3 Enter "5" for the number of saved files and click the

 button.

The Saved file name setting dialog box is displayed.

4 Check "Attach the name" and click the  button.

5 Click the  button.

1 Enter "Winder (Control data)" for the data logging name.

2 Click the  button.

The configured settings are added to the data logging setting
list.
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2 Write settings

Write the data logging settings configured in STEP 1 to the high speed data logger module.

2-1 Specify the target module 2-2 Write the settings

1 Select [Online] → [Transfer Setup].

The Transfer Setup dialog box is displayed.

2 Select "Direct connection" and click the 

button.

3 Click the  button.

4 Click the  button on the Transfer Setup dialog

box.

1 Select [Online] → [Write].

2 Click the  button.

3 Click the  button.

4 Click the  button.

The data logging settings are written to the CompactFlash card
installed on the high speed data logger module.
The data logging function starts immediately after the data are
written because the CPU mode was set to 'RUN' at Preparation.

(  Activating the system (P. 6)).
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3 Graphical display of data

Display logged data in graphs using GX LogViewer.

3-1 Start GX LogViewer

3-2 Specify the data to be displayed

Start GX LogViewer from the High Speed Data Logger Module 
Configuration Tool.

1 Select [Tool] → [Start GX LogViewer].

1 Click the  button on the "Assistant" screen.

The Transfer Setup dialog box is displayed.

GX LogViewer is started.

2 Select "Direct Connection" and click the  button.

The Logging File dialog box is displayed.

3 Double-click each folder in the following order: 

"Trigger_LOG"  "00000001".

Click the  button when the folder is not
displayed in the list.
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3-3 Display multiple cursors

3-4 Check data using the cursors

4 Select the displayed CSV file and click the  

button.

A list of data names and graphs are displayed behind the
Assistant screen.

5 Click the  button on the Assistant screen.

The data specified as target data in the data logging settings
are displayed in the graph legend area and the graph area.

* Note that in this guide, the background color was changed to
white in graph properties ([Graph View] → [Graph Properties]).
Colors of graph lines can be also changed in graph
properties.

Graph legend area Graph area

1 Select [Graph View] → [Multiple Cursor].

1 Select a graph. Move the red and blue cursors, located

at the left edge of the graph, to the desired positions
and check their respective values. 

* For an easier operation, select "Move Red Cursor Here" or
"Move Blue Cursor Here" from the menu displayed by right-
clicking on a graph area.

The difference information area is displayed.

Move the red and 
blue cursors.
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2 Check the cursor details displayed in the difference

information area.
The elapsed time and the value difference between the two
cursors (blue to red) are displayed.
In addition, the value and time of each cursor's position are
also displayed.

3 Analyze the cause of error from the graphs

• The sensor position rose rapidly (  ), and a trigger occurred

(  ).
• The feeding speed drastically decreased (  ) immediately

before the rise in sensor position, and thus, this could have
caused the trigger.

Errors are primarily diagnosed by checking the data before and
after the trigger occurrence.

Difference 
information area

Trigger occurred!
Intersecting point of 
graph with red cursor

Intersecting point of 
graph with blue cursor
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CASE 2 Creating reports from continuously logged data

This section explains 'continuous logging function' and 'report creation' using Xbar-R management chart as an 
example.

Figure

The thickness of the film (measured data) is measured at four points, and recorded in the report named Xbar-
R management chart (Excel format).

Data logging settings

Report settings

Operation flow

Target data : Position [D100 (Double word [signed])],

Measured data (1) [D510 (Word [signed])], Measured data (2) [D511 (Word [signed])],

Measured data (3) [D512 (Word [signed])], Measured data (4) [D513 (Word [signed])]

Data sampling interval : 2 seconds

Saved file format : Binary file

Report output data : Target data, production item [D502 (String)], creation time

Number of logging lines in a report : 25

Report creation period : 50 seconds

Logging data

Position*1 [D100]

(Production item: MB-5Z6004K [D502])

Direction

Continuously logs positions 

and measured data

Winder

Feeder

*1: Length from the core of the feeder.

Measured data (3) [D512]

Measured data (4) [D513]

Measured data (1) [D510]

Measured data (2) [D511]

STEP 1: Data logging settings
(Continuous logging) 

Configure the data 

logging settings using 

High Speed Data Logger 

Module Configuration Tool.

STEP 2: Report settings

Configure the report settings 

using High Speed Data 

Logger Module Configuration 

Tool.

STEP 3: Write settings

Write the data logging settings 

and report settings configured 

in STEP 1 and 2 to the high 

speed data logger module.

STEP 4: Checking created 
               report

Check the report file created 

on the CompactFlash card of 

the high speed data logging 

module on Excel.
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1 Data logging settings (Continuous logging)

Configure the settings to log the programmable controller CPU data at the specified data sampling interval.

1-1 Start High Speed Data Logger Module
Configuration Tool

1-2 Display the data logging setting screen

1-3 Select the logging type and the file
format

1-4 Select the data sampling method

Select [MELSOFT Application] → [Logging Function]*1 →
[High Speed Data Logger Module Configuration Tool] from
"Start" of Windows®*2.
*1: Does not appear in Windows 8 or later.
*2: Select [All apps] in the Start screen or [Start] →
     [All Programs]/[All apps].

1 Click the  button.

2 Click the  button.

The wizard screen to configure the data logging settings is
displayed.

1 Select "Continuous logging" for the logging type, and

"Binary file" for the file format.

2 Click the  button.

Remark

When using the report creation function, the data
logging file format must be set to "Binary file".

1 Select "General sampling", and enter "2" for "Time

specification".

2 Click the  button.
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1-5 Set the target data

1-6 Set the logging period

To set the target data, specify devices individually, or specify
consecutive devices in batch.

1 Enter the target data. (Individual)

Enter data as shown in the screen below.

Default values are automatically displayed for "Device" (Last),
"Access target CPU", "Data type", and "Output Format".

2 Click the  button. (Batch)

Set the consecutive devices in batch.

The Batch data insertion dialog box is displayed.

3 Enter the information regarding the target data, and

click the  button.
Specify data as shown in the screen below.
Enter the data name after "Change" is checked.

The specified data are added to the list.

4 Click the  button.

Use the default settings for the logging period.

1 Click the  button.
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1-7 Configure the binary output settings

1-8 Configure the save settings

Use the default settings for the binary output settings.

1 Click the  button.

1 Enter "Xbar-R" for the file save destination.

A folder with the name specified above is created on the
CompactFlash card.

2 Select "Condition specification" for the file switching

timing, and click the  button.

The File switching condition setting dialog box is displayed.

3 Select "Fixed cycle", enter "50", and click the 

button.

4 Enter "5" for the number of saved files and click the

 button.

The Saved file name setting dialog box is displayed.

5 Check "Attach the name" and click the  button.

6 Click the  button.
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1-9 Enter the data logging name

1 Enter "Winder (Management data)" for the data logging

name.

2 Click the  button.

The configured settings are added to the data logging setting
list.
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2 Report settings

Configure the settings to create a report (Excel format) using data sampled by the high speed data logger module.

2-1 Display the report setting screen 2-2 Select the data sampling method

2-3 Display the "Layout setting" screen

1 Click "Report setting" on the tree and click the 

button.

The wizard screen to configure the report settings is displayed.

Use the default settings for the data sampling method.

1 Click the  button.

1 Click the  button.

Excel is started and the 

confirmation screen is displayed.
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2-4 Load a layout file
  

2 Click the  button.

(Click the  button for Excel 2003.)

The Layout setting dialog box is displayed.

In this guide, the layout is set by using the provided layout file

(l08147eng-layout_a.xls). ( Preparation (P. 5))
Copy the layout sheet to the sheet used for layout setting.

1 Select  → [Open] on Excel 2007.

(For Excel 2003, select [File] → [Open].)

The Open dialog box is displayed.

2 Select the acquired "l08147eng-layout_a.xls" file and

click the  button.

The "Xbar-R Management chart" sheet is displayed with tables
and graphs.

3 Right-click on the sheet tab and select "Move or Copy".

The Move or Copy dialog box is displayed.

4 Check "Create a copy".
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2-5 Specify the production item5 Select "QD81DL96YYYYMMDD ... .xls" from the list of

"To book".

6 Select "Sheet1" from the list of "Before sheet", and click

the  button.

The "Xbar-R Management chart" sheet is copied to the file
"REP01" on which the layout settings are configured.

Close "l08147eng-layout_a.xls" because it is not used for the
later operation.

Remark

Precautions on changing a sheet name
A sheet name must be changed by using the

 button on the Layout setting dialog
box. If the sheet name is changed using other
methods, the layout settings will not configure
properly.

Designate a cell in the report file to display the production item
code (current data stored in D502).

1 Select "Current value" for "Adding a new layout", and

click the  button.

The Current value layout dialog box is displayed.

2 Specify the data for "Production item" (except for the

cell range).
Enter data as shown in the screen below.

3 Click the  (selection of cell range) button.

The Selection of cell range dialog box is displayed.
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2-6 Specify the data output day4 Select the cell to the right of "Production item" and click

the  button.

5 Click the  button.

The current value layout is added to the list on the Layout
setting dialog box.

Designate a cell in the report file to display the report creation
time.

1 Select "Creation time" and click the  button.

The Creation time layout dialog box is displayed.

2 Enter "Data output day" for the layout name.

3 Click the  (selection of cell) button.

The Selection of cell dialog box is displayed.

4 Select the cell to the right of "Data output day" and click

the  button.
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2-7 Specify the logging data

5 Click the  button.

The creation time layout is added to the list on the Layout
setting dialog box.

Designate the cells labelled 'position' and 'measured data' in
the report file to display the logging data (D100, D510 to
D513).

1 Select "Data logging" and click the  button.

The Data logging layout dialog box is displayed.

2 Specify the data used for data logging (except for the

leading cell and output data).
Enter data as shown in the screen below.

3 Click the  (selection of leading cell) button.

The Selection of leading cell dialog box is displayed.

4 Select the cell under "Position" and click the 

button.
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2-8 Finish the layout settings5 Select the logging data from No. 001 to 005 one by one

and click  (repeat the operation for each data).
Add the logging data No. 001 to 005 to the field of "Output
data".

6 Click the  button on the Data logging layout

dialog box.

The data logging layout is added to the list on the Layout
setting dialog box.

1 Click the  button.

2 Click the  button.

Three layout settings are added to the layout setting list.

3 Click the  button.
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2-9 Configure trigger settings 2-10 Set the report creation periods

2-11 Configure the save settings

1 Click the  button.

The Trigger condition setting dialog box is displayed.

2 Select "Fixed cycle", enter "50", and click the 

button.

The specified condition is applied to the wizard screen.

3 Click the  button.

Use the default settings for the report creation periods.

1 Click the  button.

1 Enter "Xbar-R" for the file save destination.

A folder with the name specified above is created on the
CompactFlash card.

2 Enter "5" for the number of saved files and click the

 button.

The Saved file name setting dialog box is displayed.



28

O
p
e
ra

ti
o
n
 o

f 
th

e
 h

ig
h
 s

p
e
e
d
 

d
a
ta

 l
o
g
g
e
r 

m
o
d
u
le

C
A

S
E

 2

2-12 Enter the report name3 Check "Attach the name" and click the  button.

4 Click the  button.

1 Enter "Winder (Management chart)" for the report

name.

2 Click the  button.

The configured settings are added to the report setting list
screen.
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3 Write settings

Write the data logging and report settings configured in STEP 1 and 2 to the high speed data logger module.

3-1 Specify the target module 3-2 Write the settings

1 Select [Online] → [Transfer Setup].

The Transfer Setup dialog box is displayed.

2 Select "Direct connection" and click the 

button.

3 Click the  button.

4 Click the  button on the Transfer Setup dialog

box.

1 Select [Online] → [Write].

2 Click the  button.

3  Click the  button.

4 Click the  button.

The data logging and report settings are written to the
CompactFlash card installed on the high speed data logger
module.
The data logging function and the report creation start immediately
after the data are written because the CPU mode was set to 'RUN'

at Preparation. (  Activating the system (P. 6))
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4 Checking created report

Use Excel to check the report created in STEP 3.

4-1 Save the report file to a personal 
computer

4-2 Check the report on EXCEL

1 Select [Online] → [File Browser].

The File Browser dialog box is displayed.

2 Double-click each folder in the following order:

"REPORT"  "Xbar-R"  "00000001".

Click the  button when the folder is not
displayed in the list.

3 Select the XLS file and click the  button.

4 Specify the save destination (option) on the Save As

dialog box, and click the  button.

5 Click the  button on the File Browser dialog box.

1 Open the XLS file saved in a personal computer.

2 Check that the logged data are applied to the table and

graphs on the "Xbar-R Management chart" sheet.
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Excel, Windows, Windows Vista, and Windows XP are either registered trademarks or trademarks of 
Microsoft Corporation in the United States and/or other countries.

The company names, system names and product names mentioned in this manual are either registered 
trademarks or trademarks of their respective companies.

In some cases, trademark symbols such as '™' or '®' are not specified in this manual.

This concludes the Quick Start Guide on the high speed data logger module.

The high speed data logger module supports a number of functions in addition to the logging function and report 
function introduced in this guide.

For details on the functions, refer to the following manual:

 High Speed Data Logger Module User's Manual  SH-080818ENG
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